股票十倍杠杆原理你的位置:网上配资平台开户-股票十倍杠杆原理 > 股票十倍杠杆原理 > 通达信牛魔王实盘冠军副图指标公式(附源码破译、测评和源码)
通达信牛魔王实盘冠军副图指标公式(附源码破译、测评和源码)

发布日期:2024-01-25 06:21    点击次数:196

  

编程思路破译

填充背景

涨停赋值:如果1日前的收盘价*1.1-收盘价<0.01,返回1,否则返回0

LC赋值:1日前的收盘价

操作线赋值:收盘价-LC和0的较大值的2日[1日权重]移动平均/收盘价-LC的绝对值的2日[1日权重]移动平均*100

震仓线赋值:45

抄底线赋值:20

PP赋值:操作线<震仓线 AND 1日前的操作线>震仓线 

PP3赋值:操作线<抄底线 AND 1日前的操作线>抄底线

HH赋值:统计13日中满足涨停的天数>=1

A1赋值:收盘价的5日简单移动平均

A2赋值:收盘价的10日简单移动平均

A3赋值:收盘价的20日简单移动平均

A4赋值:收盘价的30日简单移动平均

输出XG :(1日前的PP AND HH) OR (1日前的PP3 AND HH) ANDC>A1 AND A1>A2 AND A2>A3 AND A3>A4 AND 收阳线

当满足条件XG时,在0和2位置之间画柱状线,宽度为3,1不为0则画空心柱.,画黄色

当满足条件XG时,在9和11位置之间画柱状线,宽度为3,1不为0则画空心柱.,画黄色

当满足条件XG时,在8位置书写文字,画黄色

当满足条件XG时,在1位置画9号图标

当满足条件XG时,在2位置画2号图标

当满足条件XG时,在3位置画1号图标

当满足条件XG时,在4位置画1号图标

当满足条件XG时,在5位置画1号图标

当满足条件XG时,在6位置画1号图标

当满足条件XG时,在7位置画28号图标

当满足条件XG时,在8位置画1号图标

当满足条件XG时,在9位置画1号图标

当满足条件XG时,在10位置画9号图标

当满足条件XG时,在11位置画1号图标

程序源码

DRAWGBK(CLOSE>0,RGB(0,108,108),RGB(88,0,0),0,5,0);

涨停:=IF(REF(C,1)*1.1-C<0.01 ,1,0);

LC:=REF(C,1);

操作线:=SMA(MAX(C-LC,0),2,1)/SMA(ABS(C-LC),2,1)*100;

震仓线:=45;

抄底线:=20;

PP:=操作线<震仓线 AND REF(操作线,1)>震仓线 ;

PP3:=操作线<抄底线 AND REF(操作线,1)>抄底线;

HH:=COUNT(涨停,13)>=1;

A1:=MA(CLOSE,5);

A2:=MA(CLOSE,10);

A3:=MA(CLOSE,20);

A4:=MA(CLOSE,30);

XG :(REF(PP,1) AND HH) OR (REF(PP3,1) AND HH) AND

C>A1 AND A1>A2 AND A2>A3 AND A3>A4 AND C>O;

STICKLINE(XG,0,2,3,1),COLORYELLOW;

STICKLINE(XG,9,11,3,1),COLORYELLOW;

DRAWTEXT(XG,8,' 冠军'),COLORYELLOW;

DRAWICON(XG,1,9);

DRAWICON(XG,2,2);

DRAWICON(XG,3,1);

DRAWICON(XG,4,1);

DRAWICON(XG,5,1);

DRAWICON(XG,6,1);

DRAWICON(XG,7,28);

DRAWICON(XG,8,1);

DRAWICON(XG,9,1);

DRAWICON(XG,10,9);

DRAWICON(XG,11,1);

注:

       馆内各种公式为学习编程而保存,实战使用前一定要看其中是否有未来函数并自己亲自测试成功率,决不能依据公式名称的描述和形容去投资,据此入市造成投资损失由投资者自己承担。

       发文不易,如获益,欢迎赞赏,赞赏必复!

本站仅提供存储服务,所有内容均由用户发布,如发现有害或侵权内容,请点击举报。

Powered by 网上配资平台开户-股票十倍杠杆原理 @2013-2022 RSS地图 HTML地图

Copyright 365站群 © 2014-2024 联华证券 版权所有